Pulling tape too quickly - dashes on measurement screen

Love this new tape measure. However I am wondering if I am doing anything incorrectly. When measuring and pulling the tape out fairly quickly, I get dashes on the measurement screen and am wondering if I either setup the tape incorrectly or there is an adjustment I need to make during set up. Or do I need to slow down? Have reinstalled the firmware multiple times to do the set ups. Blade selection - is it a black box with white writing that is selecting that particular blade?

Hello! Assuming you are on the latest firmware (0.4.9 as of now), then dashing at high speeds is normal and part of the error checking process. Dashing indicates there is some percentage chance that an inaccurate measurement could be displayed so it indicates to the user to slightly move the tape to confirm its location before displaying anything inaccurate (and is how we ensure a 0.02" or 0.5mm accuracy).

this is a HORRIBLE “feature”! I get dashes 80% of the time and the fix is to pull it out slowly. or pull it out normally and slowly retract a few inches then pull again to what I needed to measure. This makes this tool pretty much useless to me. I used it and tried to get used to pulling and getting a measurement for a couple weeks, but I guess after being a carpenter for 35+ years, new technology needs to improve more to catch up with someone that REALLY uses a tape! I tried contacting support 3 times and go no response - so I will put it out here for others to be aware of this MAJOR shortcoming!!!

What firmware version are you on as this should be an occasional occurrence but may be happening because you are running an old version of the firmware. Also please DM me your email as all support inquiries are generally answered within 24 hours

Hey Michael, it looks like your ticket was responded to on January 3rd about an hour after you reached out, can you check your spam folder or feel free to reach out again and happy to respond

running V.0.4.9
I checked my spam/junk/ and sorted files for anything with @Recon or @ROC

Hey Michael, we responded to your email on January 3rd shortly after you reached out. If you dont see it, please respond on that thread and we can resend!