T1 Tomahawk keeps resetting at random intervals

I just received my long awaited T1 Tomahawk today, and at first it was smooth sailing. Was able to make it through firmware update (0.4.9) after connecting to the app. However the top display will periodically reset, displaying the startup screen that just says T1 and has the Reekon logo. There seems to be no direct cause because at first it was happening when I would pull the tape out to take a measurement, and after resetting it would display dashes until I moved the blade again. I attempted to reinstall the firmware but it doesn’t make it all the way through the install process before the display flashes and tries to begin blade setup again. I’ve tried proceeding with blade setup and have not been able to make it more than 2 steps before the display flashes and takes me to the beginning of the process again. Mind you I’m talking about the top measurement readout when I say display, and I am not referring to the e-paper display which I understand flickers periodically. Is this being caused by a firmware issue or by the battery? I have tried pulling the battery to reset manually, and then installing firmware again. Currently I’m stuck.

Hey Marshall, please send an email with the above details along with a video of it resetting to contact@reekon.tools and well be happy to take a look and get everything figured out!

Having the same issue now, any solution to this problem?

Hey RoanH, yes, please send us an email to contact@reekon.tools and we can provide a new beta firmware that solves it

I am having a similar issue

Please send us an email at contact@reekon.tools with a video and wed be happy to help figure it out